Auteur Sujet: Erreur BASE : Impossible de se connecter,vérifiez que votre BDD est sur votre DD  (Lu 3450 fois)

plus minus reset

0 Membres et 1 Invité sur ce sujet

Hors ligne bertold

  • Néophyte
  • *
  • Messages: 3
HP Pavilion 1620.fr XP sp3 Intel Pentium D. dd 226 Go,199 Go Dispo.
Date/heure de migration: 18-07-2008 13:59:21
Version de Windows: 5.01.2600
Compte utilisateur: HP_Administrateur
est membre du groupe des administrateurs.
Firebird version embedded est installé
Version de migration_base.exe: 5100.800.0.0
Version de Ancestrologie.exe en place: 790
Version de Ancestrologie.exe déclarée en BDR :790
Base à mettre à jour: C:\Program Files\Ancestrologie\Database\Ancestrologie.bdd
Version déclarée en BDR: 5.057
Connecté en Administrateur, au lancement de Ancestrologie,message "Erreur BASE : Impossible de se connecter à la base. Vérifiez que votre BDD est présente sur votre DD"
Hormis de fermer le logiciel et le bouton 'aide', je n'ai accès à aucune autre fonction.
Le fichier est bien dans C:\Program Files\Ancestrologie\Database\ANCESTROLOGIE.BDD.
Existe-t-il un problème avec des récents updates de Windows ?
Y a-t-il un moyen simple et sur pour revenir à une ancienne version de ancestrologie ou de passer à une version plus récente, tout en étant sur de récupérer la base de données ?
Cordialement
 

Hors ligne Facon

  • AncestroGrandMaitre
  • *******
  • Messages: 3 448
  • Remercié: 1 fois !
Bonjour,
En commençant par la fin:
 :arrow: Base de données b5.057
A l'occasion de la migration, une des premières tâches effectuées est la sauvegarde de ta base de données. Cette sauvegarde est stockée à l'emplacement C:\Program Files\Ancestrologie\Database. La date et l'heure de la sauvegarde sont ajoutées au nom de la base. Dans ton cas tu devrais ainsi avoir dans \Database une base de données portant le nom Ancestrologie.bdd080729-xxyy (2ç si la sauvegarde est de ce jour, xx l'heure et yy les minutes.
Si tu n'as pas de sauvegarde de ta base, je te recommande vivement de prendre soin de celle-ci.
 :arrow: Revenir à l'ancienne version Ancestrologie
Dans le cas présent du passage de v790 à v800, l'opération est accompagnée du changement de version Firebird. Par conséquent la marche arrière n'est pas aussi simple sauf si tu as sous la main le module d'installation complète de la version v790.

 :arrow: Bien que le message indiqué ne soit pas directement celui mentionné par ailleurs, ici par exemple: http://www.ancestrologie.org/forum/index.php?topic=9668.0
Je te propose de réaliser la même opération en téléchargeant la mise à jour Microsoft. Elle concerne des composants que tu n'as pas forcément sur ta machine et qui ont échappé au SP3. Pierrot a rencontré des difficultés de même nature et la solution a été le chargement des composants en question.
Christian
 

Hors ligne bertold

  • Néophyte
  • *
  • Messages: 3
Bonjour,

Merci Facon et indirectement les autres membres pour l'aide apportée via les différents 'post'. J'ai suivi les conseils et j'ai téléchargé Windows Installer 3.1 (KB893803-v2-x86.exe 2526 ko) ainsi que vcredist_x86.exe (2624 ko). J'ai créé un point de restauration Windows et ai  effectué une sauvegarde de tous les dossiers concernant Ancestrologie dans un dossier spécifique. A l'installation de Windows Installer 3.1, le système m'a signifié qu'il était inutile d'effectuer l'installation, le pc étant déjà à niveau pour cela. J'ai fait éxécuter vcredist et là, aucun problème. J'ai téléchargé depuis le site de Ancestrologie le module de mise à jour pour passer en version 2008.0.0.810 version de base 5.100. J'ai fait éxécuter migration_base.exe. Depuis hier soir, je n'ai plus de problème et, bien sûr, je me suis empressé de sauvegarder la base de données. A suivre début du fichier log de migration.
Date/heure de migration: 30-07-2008 17:54:00
Version de Windows: 5.01.2600
Compte utilisateur: HP_Administrateur
est membre du groupe des administrateurs.
Firebird version embedded est installé
Version de migration_base.exe: 5100.810.0.0
Version de Ancestrologie.exe en place: 790
Version de Ancestrologie.exe déclarée en BDR :790
 

Hors ligne FASIGO

  • Expert
  • ****
  • Messages: 123
  • Programme: 2015.1996.3.2
  • Base: 5.131
  • Système: win 10 64 bits
Bonjour,

Lors de la dernière mise à jour, vers la version 2008.800, j'ai eu le même problème, j'ai tout réinstallé avec la version de firebird 2.01 et j'ai exécuté v2-x86.exe. Tout marchait bien.
Je viens d'installer la version 2008.810 ... même problème, je viens de réexécuté v2-x86.exe, de réinstaller la version complète d'ancestrologie ... même problème ...
Y at-il une solution ?
Merci
core I3- 2 Go - Windows 8.1 64Ancestrologie 2015.19995.5
Base 5.131
Firebird 2.5.3.26780 (64) Arbre 2009.1.9.18
 

Hors ligne Facon

  • AncestroGrandMaitre
  • *******
  • Messages: 3 448
  • Remercié: 1 fois !
Bonjour,
Je pense qu'il y a une légère faute de frappe dans ton texte mais lourde de conséquences: la version Firebird associée à v800 est 2.1 et non 2.01.

Je vois que tu as exécuté à nouveau v2-x86.exe, en as-tu fait autant avec vcredist_x86.exe ? Ce dernier exécutable met en place les "assemblies" absents dans Windows.
Christian
 

Hors ligne FASIGO

  • Expert
  • ****
  • Messages: 123
  • Programme: 2015.1996.3.2
  • Base: 5.131
  • Système: win 10 64 bits
Je me suis couché tard et je n'étais pas réveillé mais c'est bien firebird 2.1 que j'ai et vcredist_x86.exe que j'ai installé. Je viens de le refaire pour voir, mais j'ai toujours le même problème
core I3- 2 Go - Windows 8.1 64Ancestrologie 2015.19995.5
Base 5.131
Firebird 2.5.3.26780 (64) Arbre 2009.1.9.18
 

Hors ligne bertold

  • Néophyte
  • *
  • Messages: 3
Bonjour,

Lors de la dernière mise à jour, vers la version 2008.800, j'ai eu le même problème, j'ai tout réinstallé avec la version de firebird 2.01 et j'ai exécuté v2-x86.exe. Tout marchait bien.
Je viens d'installer la version 2008.810 ... même problème, je viens de réexécuté v2-x86.exe, de réinstaller la version complète d'ancestrologie ... même problème ...
Y at-il une solution ?
Merci
Bonjour,
Je ne sais pas si 'éxécuter la migration' et 'réinstaller ancestrologie' équivalent aux mêmes traitements et mêmes résultats attendus mais, toujours est-il que quand j'ai parlé de migration, je n'ai fait que télécharger et éxécuter le programme 'migration_base.exe de 8311 ko'. Je n'ai pas télécharger le programme Installation complète. A toutes fins utiles, en fichiers joints, le contenu actuel de mon dossier Ancestrologie ainsi que la configuration 'Ancestrologie'. Ne peux-tu pas repartir d'une sauvegarde précédente ?
Désolé du peu d'aide.

Cordialement

[Fichier joint supprimé par l'administrateur]
 

Hors ligne Facon

  • AncestroGrandMaitre
  • *******
  • Messages: 3 448
  • Remercié: 1 fois !
Bonjour,
Comme il est indiqué par Bertold, migration et installation n'ont pas les mêmes effets.
En particulier, le passage en version de base b5.100 s'accompagne obligatoirement du passage de Firebird embedded de la version v2.0x à v2.1. Dans la migration, cette opération s'effectue par le remplacement des composants en question par ceux relatifs à la version FB 2.1.
Au cours de l'installation, il tombe sous le sens que c'est directement les bons composants de FB embedded qui sont mis en place dans \Program Files\Ancestrologie. Il se trouve toutefois que l'installation met en place également un fichier portant le nom Microsoft.VC80.CRT.manifest qui n'existe pas dans la migration.
Ce "manifest" permet de retrouver un groupement de dlls (un assembly Side by Side) dans \WINDOWS\WinSxS à condition toutefois que ce groupement existe.

A priori, tous les composants en question pour le bon fonctionnement de Firebird sont disposés dans \Program Files\Ancestrologie

 :arrow: Ce serait intéressant que Fasigo nous indique si dans \WINDOWS\WinSxS il retrouve le dossier \x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.42_x-ww_0de06acd, ce dossier contient les trois dlls: msvcm80.dll, msvcp80.dll et msvcr80.dll toutes à la version 8.0.50727.42 créées et modifiées le 23 septembre 2005, 08:29:16

 :arrow: De même je lui suggère de sortir le fichier Microsoft.VC80.CRT.manifest du répertoire Ancestrologie et d'essayer à nouveau de faire fonctionner Ancestrologie.
Christian
 

Hors ligne FASIGO

  • Expert
  • ****
  • Messages: 123
  • Programme: 2015.1996.3.2
  • Base: 5.131
  • Système: win 10 64 bits
Bonjour,

Merci de vous pencher sur mon problème.
Je suis sous vista, ce qui explique peut-être que je n'ai pas trouvé le réperoire en question, le plus prêt est : x86_microsoft.vc80.atl_1fc8b3b9a1e18e3b_8.0.50727.42_none_dc990e4797f81af1. Ce dossier contient bien les dll en question, mais elles dates du 24-1-2008.
J'ai enlevé le fichier Microsoft.VC80.CRT.manifest, j'ai le même résultat.
Enfin, je vous joins mon fichier migration en vous précisant que j'ai firebird server :
Date/heure de migration: 01-08-2008 05:47:34
Version de Windows: 6.00.6001
Compte utilisateur: Pierre
est membre du groupe des administrateurs.
Firebird version embedded n'est pas installé.
Version de migration_base.exe: 5100.810.0.0
Version de Ancestrologie.exe en place: 801
Version de Ancestrologie.exe déclarée en BDR :801

core I3- 2 Go - Windows 8.1 64Ancestrologie 2015.19995.5
Base 5.131
Firebird 2.5.3.26780 (64) Arbre 2009.1.9.18
 

Hors ligne Facon

  • AncestroGrandMaitre
  • *******
  • Messages: 3 448
  • Remercié: 1 fois !
Bonjour,
Tu as apporté deux précisions importantes:
-1- Tu es sous Vista. La documentation Microsoft précise bien les systèmes d'exploitation compatibles avec l'exécutable vcredist_x86.exe
Systèmes d'exploitation pris en charge : Windows 2000 Service Pack 3; Windows 98; Windows 98 Second Edition; Windows ME; Windows Server 2003; Windows XP Service Pack 2

Il est plus que probable que Vista ait les bibliothèques recherchées sous la forme d'assembly. Elles doivent être situées dans des répertoires systèmes cachés.

-2- Tu indiques également que Firebird Server est installé et par ailleurs, l'extrait du fichier migration.log montre bien que FB embedded n'est pas installé ou plus probablement qu'il est présent mais stoppé. Pour pouvoir fonctionner avec FB Server, il faut que ce dernier soit à la bonne version, c'est à dire FB 2.1 ou même depuis peu FB 2.1.1.
Peux-tu nous indiquer la version du FB Server installé et s'il est bien en service.



Christian
 

Hors ligne FASIGO

  • Expert
  • ****
  • Messages: 123
  • Programme: 2015.1996.3.2
  • Base: 5.131
  • Système: win 10 64 bits
Bonjour,
FB server fonctionne et il est actif. J'ai la version 2.1.0.17798 firebird 2.1.

A l'instant je viens de me souvenir que DDdeBerdeux demandait de supprimer GDS32.dll du répertoire ancestrologie, je l'avais fait la dernière fois pour résoudre mon problème. Je viens de constater qu'il est encore dans le répertoire ancestrologie, je viens donc de le supprimer ... et ça marche.

Si je comprend bien, il faudra le faire à chaque mise à jour !

Merci encore.
core I3- 2 Go - Windows 8.1 64Ancestrologie 2015.19995.5
Base 5.131
Firebird 2.5.3.26780 (64) Arbre 2009.1.9.18
 

Hors ligne Facon

  • AncestroGrandMaitre
  • *******
  • Messages: 3 448
  • Remercié: 1 fois !
Bonjour,
Ce qui veut dire:
 :arrow: Que l'extrait du fichier migration.log était issu d'un fichier élaboré à l'occasion d'une migration ancienne. Dans la suite des opérations, tu es passé par une nouvelle installation Ancestrologie sans avoir nettoyé le répertoire Programmes\Ancestrologie et à cette occasion, l'installation a remis en place FB embedded.
Comme tu n'avais pas neutralisé FB embedded, c'est lui qui était prioritaire au démarrage d'Ancestrologie.
Pour neutraliser FB embedded, tu peux éliminer gds32.dll ou encore le renommer gds32.dll.STOP ce qui permet éventuellement de repasser rapidement sur embedded.

 :arrow: A l'occasion d'une migration ou d'une mise à jour, dans le processus il est vérifié si gds32.dll est présent. Si le fichier est absent ou si le même fichier n'est pas trouvé parce qu'il est sous un autre nom, la mise à jour de FB embedded n'est pas effectuée.
Il n'y aura par conséquent pas de gêne lors des prochaines mises à jour. La seule gêne proviendra éventuellement de la non mise à jour de FB Server qui est laissée à la discrétion de l'utilisateur. C'est d'ailleurs écrit dans les messages qui apparaissent lors des migrations ou mises à jour.
Christian
 

AC

  • Invité
Erreur BASE : Impossible de se connecter,vérifiez que votre BDD est sur votre DD
« Réponse #12 le: 10 Novembre 2008 à 20:01:07 »
Bonsoir,
je viens de faire la nouvelle mise à jour (v991) mais en ouvrant le logiciel j'ai le meme message d'erreur : erreur base, impossible de se connecter à la base. Pourriez-vous m'indiquer comment recuperer ma bdd.
D'avance merci
AC
 

mpl75

  • Invité
Erreur BASE : Impossible de se connecter,vérifiez que votre BDD est sur votre DD
« Réponse #13 le: 10 Novembre 2008 à 20:07:02 »
Vous aurez sûrement des propositions.
Mais ce thème récurrent trouve souvent une solution en parcourant le forum et sa "Recherche", la question est mille fois abordée.

Avouez que le conseil "Aide-toi le ciel t'aidera" ou "Cherchez, vous trouverez" s'adapte bien  :?:
On m'a dit "Si tu veux aider , ne donne pas la réponse, mais dit comment trouver la réponse", ce que je viens de faire.
« Modifié: 10 Novembre 2008 à 20:10:36 par mpl75 »
 

Tags: