Auteur Sujet: Pb d'attribution d'un témoin  (Lu 8249 fois)

plus minus reset

0 Membres et 1 Invité sur ce sujet

Hors ligne DDdeBerdeux

  • AncestroGrandMaitre
  • *******
  • Messages: 3 278
  • Remercié: 4 fois !
Pb d'attribution d'un témoin
« Réponse #19 de la page précédente: 25 Novembre 2005 à 10:12:39 »
: "Sophie"
J'ai rencontré le problème il y a quelques temps, puis cela avait été résolu. Et depuis le passage en base 4.0 il est réapparu
Je ne voudrai pas avoir l'air susceptible, mais ton message pourrai faire croire que c'est le passage en base v4.00 qui provoque l'erreur. Il n'y a qu'a lire ce fil depuis le début.

Le problème est apparu début juillet lors de modifications pour le fonctionnement de la dll Les Arbres je crois ou un peu avant, puis il a disparu avec la version 363, pour réapparaître avec la version 370 (mi juillet?).

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne Sophie

  • AncestroExpert
  • *****
  • Messages: 617
    • http://www.lagazettedesancetres.com
Pb d'attribution d'un témoin
« Réponse #20 le: 25 Novembre 2005 à 19:21:01 »
Je n'ai fait que retracer le cours des évènements sur mon ordinateur. Comme on l'a vu, ce phénomène est aléatoire. Il est apparu, a disparu puis est réapparu.

Je ne sais pas ce qui le provoque, je ne peux donc émettre de jugement.



Je ne voulais pas te blesser, je suis trop admirative du travail effectué pour me plaindre de quoi ce soit (la preuve, s'il n'y avait pas eu le post je n'aurais rien dit !)



De l'inconvénient des forums : il est parfois difficile de bien se faire comprendre  :wink:
 

Hors ligne DDdeBerdeux

  • AncestroGrandMaitre
  • *******
  • Messages: 3 278
  • Remercié: 4 fois !
Pb d'attribution d'un témoin
« Réponse #21 le: 26 Novembre 2005 à 11:43:48 »
Non non, je ne suis ni vexé, ni blessé. Je voulais juste être plus clair.

Merci

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne Gvx

  • AncestroJunior
  • ****
  • Messages: 361
Pb d'attribution d'un témoin
« Réponse #22 le: 28 Novembre 2005 à 22:28:14 »
Je viens d'essayer comprendre les problèmes d'attribution de de témoin. Voici les différent test effectués et leur résultats.



1er cas

1/ création d'un individu (sans cliquer sur enregistrer)

2/ création d'un événement (date)

3/ ajout d'un témoin (création)

4/ fermer événement

5/ enregistrer individu



Tout OK



2eme cas

Ajout d'un témoin dans l'événement precedent (sélection) pas de nom dans le tableau (acces au type de témoin)

Aprés validation et retour sur l'événement le témoin n'existe pas :!:



En visualisant la table T_ASSOCIATIONS avec le BOA je constate que ASSO_KLE_ASSOCIE contient un nombre trés grand



3eme cas

1 / Creation d'un événement (sans témoin)

2/  fermer événement

3/ ouvrir événement ajouter un témoin (sélection) pas de nom dans le tableau (acces au type de témoin)

Aprés validation et retour sur l'événement le témoin n'existe pas :!:



En visualisant la table T_ASSOCIATIONS avec le BOA je constate que ASSO_KLE_ASSOCIE contient zéro



Si d'autres pouvaient confirmer ces différents cas, ou en trouver d'autres cela devrait aider PCM a trouver le bug :wink:



De plus ce bug crée des temoins fantomes dans les exports gedcom voir ce fil



PS: voici la requête pour le BOA afin de visualiser la table T_ASSOCATIONS (penser a changer le N° de dossier)

:
select * from  T_ASSOCIATIONS  where  ASSOC_KLE_DOSSIER =1

Hors ligne DDdeBerdeux

  • AncestroGrandMaitre
  • *******
  • Messages: 3 278
  • Remercié: 4 fois !
Pb d'attribution d'un témoin
« Réponse #23 le: 28 Novembre 2005 à 23:40:53 »
J'ai essayé de reproduire tes essais.

Peut-être faudrait-il distinguer témoins d'évènements individuels de témoins d'évènements familiaux.

Pour les évènements familiaux, j'en ai créé cet après-midi, sans problème.

Pour les évènements individuels, quand tu dis "pas de nom dans le tableau", çà veut dire que bien qu'on ait sélectionné un individu dans la fénêtre de sélection, le champ nom reste vide. Je ne vois pas trop la différence entre les essais 2 et 3, chez moi j'ai une valeur ENORME dans le champ ASSOC_CLE_ASSOCIE. Je n'ai pas sélectionné de type, dans la table il reste à 0, normal.

A+

André

PS: à mon avis, l'erreur se produit juste après la sélection de l'individu témoin, c'est pour celà que le champ reste vide.
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne Gvx

  • AncestroJunior
  • ****
  • Messages: 361
Pb d'attribution d'un témoin
« Réponse #24 le: 29 Novembre 2005 à 22:40:19 »
: "DDdeberdeux"
Je ne vois pas trop la différence entre les essais 2 et 3


Dans le cas 3 je ferme la fenêtre de l'evenement (enregistrement de l'evenement?). Ensuite je l'ouvre a nouveau pour ajouter un témoin. Dans ce cas le champ ASSO_KLE_ASSOCIE est egale à zéro (au lieu d'un nombre énorme)

Hors ligne Ransac

  • Modérateur Global
  • AncestroGrandMaitre
  • *****
  • Messages: 3 015
  • Remercié: 1 fois !
    • bases des villes
  • Programme: 2015-1996.3
  • Base: 5.131
  • Système: Windows vista, Windows 7, Windows 10
Pb d'attribution d'un témoin
« Réponse #25 le: 30 Novembre 2005 à 09:42:53 »
: "DDdeberdeux"
Peut-être faudrait-il distinguer témoins d'évènements individuels de témoins d'évènements familiaux.
jusqu'à maintenant, les problèmes me semblent être qu'avec les ténions des événements individuels. Je n'ai jamais eu de problème pour les témoins d'événements familiaux ! Mais ais-je eu de la chance ?
N'oubliez jamais que le mieux est l'ennemi du bien  et que la perfection n'est pas de ce monde !
Les définir est un défi, les réaliser est un leurre !    ... mais on aimerait tellement y croire!
 

Hors ligne Gvx

  • AncestroJunior
  • ****
  • Messages: 361
Pb d'attribution d'un témoin
« Réponse #26 le: 01 Décembre 2005 à 21:47:47 »
Une petite remaque au passage. Est-il normal d'être son propre temoin :shock:  :lol:  :lol:

Hors ligne DDdeBerdeux

  • AncestroGrandMaitre
  • *******
  • Messages: 3 278
  • Remercié: 4 fois !
Pb d'attribution d'un témoin
« Réponse #27 le: 01 Décembre 2005 à 23:18:06 »
: "Gvx"
Est-il normal d'être son propre temoin :shock:  :lol:  :lol:
C'est peut-être çà qu'on appelle un remaque :D

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne Gvx

  • AncestroJunior
  • ****
  • Messages: 361
Pb d'attribution d'un témoin
« Réponse #28 le: 05 Décembre 2005 à 20:22:50 »

Tags: