Auteur Sujet: [terminé]Base (b4.027) b4.028 en test  (Lu 9351 fois)

plus minus reset

0 Membres et 1 Invité sur ce sujet

Hors ligne JiPSchiff

  • AncestroExpert
  • *****
  • Messages: 801
    • jipschiff.com
[terminé]Base (b4.027) b4.028 en test
« Réponse #19 de la page précédente: 09 Mars 2006 à 15:59:20 »
: "Delettrez"
rebonsoir,



V500 b4028

essai de l'import Gedcom et de sa suppression.



PB en import: message :

 Dynamic SQL Error

SQL error code = - 206

Column unknown ID_IMPORT_GEDCOM

At line 1 column 155


individu importé partiellement sans evenements



Essai de suppresion de l'import : message erreur :

 Field 0 not found,



individus non supprimés :(



conséquence de l'erreur d'import?



j'arrête pour ce soir :!:



A plus



Jean




Tentative d'import gedcom et suppression:j'ai les mêmes messages.
Ancestrologie V1228 B5122
PIV 3G° 1024M° 2 Ecrans 19p
OS XP sp3
Ancestrologie V1228 B5122
Portable Intel Core 2 17P
OS Vista Home SP2
 

Hors ligne jdelettrez

  • Grand Amateur
  • ***
  • Messages: 25
    • Genealogie Delettrez
  • Programme: 1.340
  • Base: 5.130
  • Système: windows 7
[terminé]Base (b4.027) b4.028 en test
« Réponse #20 le: 09 Mars 2006 à 19:44:23 »
Bonsoir ,

Je rentre du boulot.

Vérification de la présence du champ  ID_IMPORT_GEDCOM :



Présent dans INDIVISU, EVENEMENT_FAM

Absent dans MULTIMEDIA



Les procédures citées sont toutes présentes



J'essaye en ajoutant a la main le champ dans MULTIMEDIA



A+

Jean
 

Hors ligne DDdeBerdeux

  • AncestroGrandMaitre
  • *******
  • Messages: 3 244
  • Remercié: 2 fois !
[terminé]Base (b4.027) b4.028 en test
« Réponse #21 le: 09 Mars 2006 à 20:19:53 »
Je viens d'examiner le gedcom de jipschiff, il y a la même absence et en plus la procedure PROC_PURGE_IMPORT n'est pas la bonne.

Celà vient de ce que ces bases ont travaillées avec la bêta V495 du logiciel où la méthode n'était pas au point.

S'il s'agit de bases de tests, c'est pas grave, mais si vous avez utilisé cette v495 (version exacte à confirmer par PCM), sur votre base réelle, il va y avoir un problème parce que la V500 ne fait qu'une création, pas une mise à jour.

Pour que la V500 fasse son travail, il faudrait suuprimer au moins la procédure PROC_PURGE_IMPORT et la table T_IMPORT_GEDCOM. Je pense que çà devrait être suffisant pour que la v500 recrée tout comme il faut ( avec peut-être des messages d'erreurs pour le générateur et les champs existants).

Il y a beaucoup de personnes concernées? Dans ce cas je pourrai faire un script permettant au logiciel de recréer correctement les tables et procédures.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne jdelettrez

  • Grand Amateur
  • ***
  • Messages: 25
    • Genealogie Delettrez
  • Programme: 1.340
  • Base: 5.130
  • Système: windows 7
[terminé]Base (b4.027) b4.028 en test
« Réponse #22 le: 09 Mars 2006 à 20:20:07 »
Je viens d' ajouter le Champ ID_IMPORT_GEDCOM( integer )

au fichier MULTIMEDIA

une erreur "mauvais format d'image" lors d'un premier essai.

En décochant l'option "importer les images",  import OK

Le nombre de fiches ajoutées semble correct; :lol:  

les événements aussi; :lol:  :lol:



l'examen des Champs ID_IMPORT_GEDCOM montre que le champs a la valeur 1 pour les données concernées.(c'est le premier import?)



Cerise sur le gateau : la suppression de l'import rétablit bien la base au nombre d'individus initial. :D



Moins bien toujour le message Field 0 not found, :cry: au lancement de la

demande de suppression de l'import.

le message apparait avant l'exécution de la procédure.



A+



Jean
 

Hors ligne Joël AUGUSTE

  • AncestroSenior
  • *****
  • Messages: 1 345
  • Remercié: 4 fois !
    • http://gw.geneanet.org/joelauguste
  • Programme: v2015-1996.3
  • Base: 5.131
  • Système: W10
[terminé]Base (b4.027) b4.028 en test
« Réponse #23 le: 09 Mars 2006 à 20:42:28 »
: "DDdeberdeux"
Celà vient de ce que ces bases ont travaillées avec la bêta V495 du logiciel où la méthode n'était pas au point.

S'il s'agit de bases de tests, c'est pas grave, mais si vous avez utilisé cette v495 (version exacte à confirmer par PCM), sur votre base réelle, il va y avoir un problème parce que la V500 ne fait qu'une création, pas une mise à jour.

Pour que la V500 fasse son travail, il faudrait suuprimer au moins la procédure PROC_PURGE_IMPORT et la table T_IMPORT_GEDCOM. Je pense que çà devrait être suffisant pour que la v500 recrée tout comme il faut ( avec peut-être des messages d'erreurs pour le générateur et les champs existants).

Il y a beaucoup de personnes concernées? Dans ce cas je pourrai faire un script permettant au logiciel de recréer correctement les tables et procédures.


re Bonsoir...



Je m'inscris sur la liste de ceux qui ont travaillé avec des versions bêta (dont la v495) sur la base réelle ...  :oops:
Cordialement,

Joël


Ancestrologie version  v2015-1996.3 b5.131
Intel Core i3-2100, 6144M°, Ecran 21,5" (1440*900)
Windows 10 Famille
 

Hors ligne DDdeBerdeux

  • AncestroGrandMaitre
  • *******
  • Messages: 3 244
  • Remercié: 2 fois !
[terminé]Base (b4.027) b4.028 en test
« Réponse #24 le: 09 Mars 2006 à 20:57:38 »
Pour savoir si ta base est touchée par le virus de la grippe de la bêta 495 ou 498 (j'attend que PCM confirme sur qu'elle version il a créée cette procédure), et si tu n'as pas les outils pour "explorer" les procédures, crée un nouveau dossier et essaie d'y importer un petit gedcom et de le supprimer. De toute façon tu pourras supprimer ce petit dossier. Si elle tousse, c'est qu'elle est malade, et je ferai un sérum.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne jdelettrez

  • Grand Amateur
  • ***
  • Messages: 25
    • Genealogie Delettrez
  • Programme: 1.340
  • Base: 5.130
  • Système: windows 7
[terminé]Base (b4.027) b4.028 en test
« Réponse #25 le: 09 Mars 2006 à 21:03:40 »
Suite au post d'André, J'ai supprimé la table T_IMPORT_GEDCOM et la procédure PROC_PURGE_GEDCOM.



Puis, j'ai relancé Ancestrologie et controlé que la v500 les avait recréés. OK



Essai import et suppression OK



un message  a la fin de l'import (avec option import image non validé)



"Image bitmap incorrecte" :(



l'examen du fichier GEDCOM avec le BlocNote montre qu'il n'existe aucune image liée (style 2 FILE c:\image\....)

alors?



Plus de message en suppression, retour au nombre initial d'individus



Suite au nouveau post d'André, je complète :



je ne pense pas être passé par la v495 , mais de la v476? a la v498.

Enfin, je dis ca de mémoire :?



je sauvegarde un moment et si cela marche j'efface pour les vbéta.

je ne garde une sauvegarde que des version officielles.





a+ bonsoir,

Jean
 

Hors ligne JiPSchiff

  • AncestroExpert
  • *****
  • Messages: 801
    • jipschiff.com
[terminé]Base (b4.027) b4.028 en test
« Réponse #26 le: 09 Mars 2006 à 21:12:42 »
J'ai remis la base 4.022 que j'avais sauvegardé et utilisé avec la v491.

Import gedcom et suppression sans aucun problème.



Mise à jour de cette base 4.022 vers 4.028

Import gedcom et suppression sans problème.

 :lol:
Ancestrologie V1228 B5122
PIV 3G° 1024M° 2 Ecrans 19p
OS XP sp3
Ancestrologie V1228 B5122
Portable Intel Core 2 17P
OS Vista Home SP2
 

Hors ligne DDdeBerdeux

  • AncestroGrandMaitre
  • *******
  • Messages: 3 244
  • Remercié: 2 fois !
[terminé]Base (b4.027) b4.028 en test
« Réponse #27 le: 09 Mars 2006 à 21:24:05 »
: "Delettrez"
J'ai supprimé la table T_IMPORT_GEDCOM et la procédure PROC_PURGE_GEDCOM. Puis, j'ai relancé Ancestrologie et controlé que la v500 les avait recréés. OK
Sans le moindre message d'erreur d'ancestrologie? Parce qu'il doit tenter de tout recréer (la liste dans mon message de ce matin), mais il est possible que si une création est refusée, il continue quand même pour la création suivante etc.. Dans ce cas c'est bon. Sans celà il faudra faire un script qui détricote le tout.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne Joël AUGUSTE

  • AncestroSenior
  • *****
  • Messages: 1 345
  • Remercié: 4 fois !
    • http://gw.geneanet.org/joelauguste
  • Programme: v2015-1996.3
  • Base: 5.131
  • Système: W10
[terminé]Base (b4.027) b4.028 en test
« Réponse #28 le: 09 Mars 2006 à 21:24:07 »
: "DDdeberdeux"
Pour savoir si ta base est touchée par le virus de la grippe de la bêta 495 ou 498 crée un nouveau dossier et essaie d'y importer un petit gedcom et de le supprimer. De toute façon tu pourras supprimer ce petit dossier. Si elle tousse, c'est qu'elle est malade, et je ferai un sérum.


Docteur, ma base tousse, je crois qu'elle a la grippe...

Je n'avais pas les outils nécessaires pour faire une exploration détaillée des entrailles, j'ai donc suivi ton conseil en créant un dossier et en important un mini gedcom.

A l'import, affichage de :

Dynamic SQL Error

SQL error code = - 206

Column unknown ID_IMPORT_GEDCOM

At line 1 column 155


A la suppression, affichage de : Field 0 not found

J'attends le sérum, mais y'a pas le feu, j'ai ni import ni export de gedcom à faire pour l'instant...

Si possible, pas trop difficile à inoculer, je suis douillet  :wink:
Cordialement,

Joël


Ancestrologie version  v2015-1996.3 b5.131
Intel Core i3-2100, 6144M°, Ecran 21,5" (1440*900)
Windows 10 Famille
 

Hors ligne DDdeBerdeux

  • AncestroGrandMaitre
  • *******
  • Messages: 3 244
  • Remercié: 2 fois !
[terminé]Base (b4.027) b4.028 en test
« Réponse #29 le: 09 Mars 2006 à 22:08:23 »
Je viens de mettre une seringue de sérum à télécharger ICI . Si quelqu'un peut l'essayer sur sa base malade, en ayant pris soin d'en avoir fait un clône avant, c'est plus sûr.

Cà fonctionne comme une procédure de mise à jour de la base.

Cà devrait enlever le virus MéchantBêta495, ce qui permettra à la v500, d'installer correctement ce qu'il faut pour la procédure de suppression d'un import gedcom.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne JiPSchiff

  • AncestroExpert
  • *****
  • Messages: 801
    • jipschiff.com
[terminé]Base (b4.027) b4.028 en test
« Réponse #30 le: 09 Mars 2006 à 22:21:29 »
J'ai remis la base"malade",injecté le sérum.

Import gedcom et suppression sans problème.A priori la malade peut reprendre ses activités. :wink:
Ancestrologie V1228 B5122
PIV 3G° 1024M° 2 Ecrans 19p
OS XP sp3
Ancestrologie V1228 B5122
Portable Intel Core 2 17P
OS Vista Home SP2
 

Hors ligne DDdeBerdeux

  • AncestroGrandMaitre
  • *******
  • Messages: 3 244
  • Remercié: 2 fois !
[terminé]Base (b4.027) b4.028 en test
« Réponse #31 le: 09 Mars 2006 à 22:33:21 »
Un petit cachet d'optimisation ne devrait pas lui faire de mal après ce facheux épisode.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne JiPSchiff

  • AncestroExpert
  • *****
  • Messages: 801
    • jipschiff.com
[terminé]Base (b4.027) b4.028 en test
« Réponse #32 le: 09 Mars 2006 à 22:45:42 »
C'est déjà fait docteur et je l'ai mise au repos pour ce soir :lol:
Ancestrologie V1228 B5122
PIV 3G° 1024M° 2 Ecrans 19p
OS XP sp3
Ancestrologie V1228 B5122
Portable Intel Core 2 17P
OS Vista Home SP2
 

Hors ligne jdelettrez

  • Grand Amateur
  • ***
  • Messages: 25
    • Genealogie Delettrez
  • Programme: 1.340
  • Base: 5.130
  • Système: windows 7
[terminé]Base (b4.027) b4.028 en test
« Réponse #33 le: 09 Mars 2006 à 23:12:02 »
J'ai injecté le serum



Import et export OK



juste toujours le message " image Bitmap incorrecte" en fin de procédure.

J'ai essayer uvec une base ancienne b4015 qui n'avait pas vu un v495 et autre.

Je pense que cela provient du code et non des procédures  :?:



J'arrête pour ce soir,

bonsoir a tous



Jean
 

Hors ligne jdelettrez

  • Grand Amateur
  • ***
  • Messages: 25
    • Genealogie Delettrez
  • Programme: 1.340
  • Base: 5.130
  • Système: windows 7
[terminé]Base (b4.027) b4.028 en test
« Réponse #34 le: 09 Mars 2006 à 23:45:54 »
Encore moi,

j'ai chargé la base seule sur le site au point 9.

Elle n'est pas vide (Généalogie napoléon) et est en V4010 :!:  :!:



Par contre après passage en 4028 , Pas de message en import, ni en export.



Je reste quand même avec mes ancêtres et mon message.



On sait jamais, pourrait me venir des rèves de grandeur et puis l'opération se fait correctement.



A+

Cordialement



Jean
 

Hors ligne Joël AUGUSTE

  • AncestroSenior
  • *****
  • Messages: 1 345
  • Remercié: 4 fois !
    • http://gw.geneanet.org/joelauguste
  • Programme: v2015-1996.3
  • Base: 5.131
  • Système: W10
[terminé]Base (b4.027) b4.028 en test
« Réponse #35 le: 10 Mars 2006 à 09:26:26 »
: "DDdeberdeux"
Je viens de mettre une seringue de sérum à télécharger ICI . Si quelqu'un peut l'essayer sur sa base malade, en ayant pris soin d'en avoir fait un clône avant, c'est plus sûr.

Cà fonctionne comme une procédure de mise à jour de la base.

Cà devrait enlever le virus MéchantBêta495, ce qui permettra à la v500, d'installer correctement ce qu'il faut pour la procédure de suppression d'un import gedcom.


Bonjour docteur André,



Je viens d'essayer la seringue de sérum.

J'ai créé un nouveau dossier, puis importé un mini gedcom... 1er miracle, je n'ai plus l'affichage de Dynamic SQL Error...

J'ai ensuite supprimé l'import gedcom et je n'ai pas eu de message Field 0 not found.

Pour finir, j'ai même donné le cachet optimalisation...

Merci docteur, je crois que je n'ai plus le virus H5N1... Heu pardon MéchantBêta495 !
Cordialement,

Joël


Ancestrologie version  v2015-1996.3 b5.131
Intel Core i3-2100, 6144M°, Ecran 21,5" (1440*900)
Windows 10 Famille
 

Tags: