Auteur Sujet: Problème export GEDCOM  (Lu 8212 fois)

plus minus reset

0 Membres et 1 Invité sur ce sujet

Hors ligne b.callens

  • Expert
  • ****
  • Messages: 100
    • Blog personnel
  • Programme: v1040
  • Base: v5.122
Problème export GEDCOM
« le: 05 Mars 2006 à 15:53:07 »
Bonjour,



J'ai remarqué une anomalie agaçante qui m'oblige à des corrections via un autre logiciel.



Lorque je crée une famille isolée (je crée d'abord une fiche), par exemple



Père A (Marié) à mère B avec enfants X, Y, Z



A l'export GEDCom, j'ai automatiquement un mariage "fantôme" : ce qui donne :



Premier mariage Père A avec inconnue

deuxième mariage (le vrai) avec mère B



enfants x, y, z



Comment corriger ? Est-ce le résultat d'une fausse manoeuvre ?



 Merci de vos réponses et Généalogiquement vôtre !



Bruno Callens
 

Hors ligne Horemans

  • AncestroSenior
  • *****
  • Messages: 1 775
    • http://perso.wanadoo.fr/philippe.horemans
Problème export GEDCOM
« Réponse #1 le: 05 Mars 2006 à 16:02:47 »
Il me semble que ce problème est ancien, mais qu'il était résolu depuis longtemps.

Quelle version de programme as-tu ?
Plus çà va, plus je me régale...  Et avec  Quisontils, la gestion des actes, c'est facile !   Philippe
 

Hors ligne b.callens

  • Expert
  • ****
  • Messages: 100
    • Blog personnel
  • Programme: v1040
  • Base: v5.122
Probleme export gedcom
« Réponse #2 le: 05 Mars 2006 à 17:33:40 »
Bonjour,



Merci de votre réponse.



La version utilisée est la 470 (base 4.0017), donc la version la plus récente.



Généalogiquement et informatiquement vôtre !



Bruno callens
 

Hors ligne b.callens

  • Expert
  • ****
  • Messages: 100
    • Blog personnel
  • Programme: v1040
  • Base: v5.122
problème export gedcom- précision
« Réponse #3 le: 05 Mars 2006 à 17:38:39 »
Une petite précision qui peut être utile.



Lorsque j'utilisais une très ancienne version (1.7.05 je pense -c'était du temps d'interbase), le problème se présentait de temps en temps.



Maintenant, d'après ce que je vois, il ne semble se présenter (mais quasi systématiquement)  que dès lors que l'on saisit des familles isolées.



A+



Bruno callens
 

Hors ligne GERONIMO24

  • AncestroTest
  • Expert
  • ****
  • Messages: 153
  • Remercié: 1 fois
    • Arbre sur Geneanet
  • Programme: 2015-1996-3-2
  • Base: 5.131
  • Système: Windows 10
MARIAGE FANTOME
« Réponse #4 le: 30 Mars 2006 à 18:33:46 »
Bonjour



Je me greffe sur cette discution car je n'ai pas vu de réponse,  juste des questions et un constat "c'est un problème ancien".



Moi je suis en  V500 B4.017  et j'ai le même problème.



Cela fait un moment que je n'avais pas généré de fichier .ged et en utilisant  GENATOILE je me suis aperçu qu'un quard des mariages étaient doubles.  Il y a un mariage fantôme.



En regardant avec visuGed  je trouve une ligne supplémentaire:

'uni avec indéf. ?'



que puis-je faire.

Cordialement

 :?:  :?:  :?:  :?:
Matériel: PC ASUS 16 Go / 1 To  sous Win10
 

Hors ligne Claude Baudin

  • AncestroSenior
  • *****
  • Messages: 1 709
Problème export GEDCOM
« Réponse #5 le: 31 Mars 2006 à 08:30:58 »
Essaiye de passer en base 4031 et en version beta 504. :wink:
Cordialement
A+
Ancestrologie V 1101 B 5122
PIV 3G° 2048 M°
Intel core 2 duo, 2048M° Ecran 19p et 17p
OS Vista  Windows7 et Xp
___________

Claude
 

Hors ligne b.callens

  • Expert
  • ****
  • Messages: 100
    • Blog personnel
  • Programme: v1040
  • Base: v5.122
Création mariages fantômes lors d'export gedcom
« Réponse #6 le: 09 Avril 2006 à 01:22:49 »
Bonjour,



Je reviens sur ce problème non encore résolu (version 511 base 4.0.31) extrêmement agaçant car il oblige, pour nettoyer le fichier, de passer par un autre logiciel (j'utilise paf à cette fin) (si cela intéresse, je vous montre comment opérer).



Il y a un réel bogue ; pour aider, peut-être, il me semble qu'il n'apparaît aujourd'hui que dès lors où l'on saisit des familles isolées.



Généalogiquement vôtre



b.callens                   8)
 

Hors ligne Claude Baudin

  • AncestroSenior
  • *****
  • Messages: 1 709
Problème export GEDCOM
« Réponse #7 le: 09 Avril 2006 à 08:55:18 »
Vas y montre nous on est toujours avide d'apprendre  :wink:  :lol:
Cordialement
A+
Ancestrologie V 1101 B 5122
PIV 3G° 2048 M°
Intel core 2 duo, 2048M° Ecran 19p et 17p
OS Vista  Windows7 et Xp
___________

Claude
 

Hors ligne DDdeBerdeux

Problème export GEDCOM
« Réponse #8 le: 09 Avril 2006 à 10:59:35 »
Bonjour,

Une union uni-parentale est créée si un enfant n'a qu'un seul parent déclaré.

Bruno et GERONIMO ont-ils vérifiés que tous les enfants du couple ont bien pour père et mère les individus du couple?

J'ai constaté effectivement l'existence sur d'anciennes bases, d'unions uni-parentales non supprimées lorsque le deuxième parent a été trouvé. Mais également sur une récente, d'unions qui n'avaient pas été supprimées alors que l'un des individus du couple (toujours le mari?) n'est plus dans le dossier.

Pour les détecter et les supprimer, la fonction du menu Outils/ Correction de incohérences sur individus ne fonctionnant pas, utilisez le BOA et exécutez la requête: SELECT * FROM PROC_INCOHERENCES(dossier, mode) où dossier est le N° de votre dossier et mode=0 pour seulement visualiser les incohérences ou mode=1 pour également les corriger.

N'oubliez pas de valider les modifications en quittant.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne b.callens

  • Expert
  • ****
  • Messages: 100
    • Blog personnel
  • Programme: v1040
  • Base: v5.122
anomalie gedcom
« Réponse #9 le: 09 Avril 2006 à 12:57:14 »
Bonjour,



Je ne suis pas sûr de comprendre...



Enfin, dans mon cas, lorsque je n'indentifie pas le second parent d'un enfant, je le remplace de toute façon par une mention provisoire ; par exemple, pour un enfant donné, je n'ai que le nom et prénom du père (cas fréquent fin 16 ème siècle début 17ème) ; je remplace donc la mère par (pour le nom : NON IDENTIFIEE ; pour le prénom MEREENFANTX ou CONJOINTY).



Ce qui se passe est différent.



Je suis en train de saisir des notes ; essentiellement des familles (père mère et enfants ) isolées ; elles le sont parce  je ne dispose pas pour l'instant de suffisamment d'éléments pour les intégrer dans mon arbre principal (il s'agit surtout de collatéraux).



Or, dans ce cas, dans l'export gedcom, il y a systématiquement création d'un mariage fantôme.



Généalogiquement vôtre !



Bruno callens                     :)
 

Hors ligne JiPSchiff

  • AncestroExpert
  • *****
  • Messages: 801
    • jipschiff.com
Problème export GEDCOM
« Réponse #10 le: 09 Avril 2006 à 13:52:25 »
Bonjour,

Je viens d'essayer de reproduire le problème:

J'ai créé(par nouvelle fiche) un individu "Dupont Pierre",je l'ai marié à "Durant Marie"(par Conjoint +).Dans l'onglet "Union",j'ai sélectionné "Mariés".

J'ai bien enregistré,par contre sur la fiche de "Dupont Pierre",il n'apparaisssait pas de conjoint.J'ai donc quitté la fiche,sélectionné un nom au hasard dans "Répertoire",quitté cette fiche et je suis revenu à la fiche de "Dupont Pierre" et là "Durant Marie" apparaissait bien comme conjoint.J'ai créé un enfant "Dupont Robert" par "Enfants +" Enregistrer. L'enfant apparait bien sur les fiches de Dupont P. et Durant Marie.

J'ai ensuite fait un export Gedcom,réimporté ce Gedcom et aucune anomalie.
Ancestrologie V1228 B5122
PIV 3G° 1024M° 2 Ecrans 19p
OS XP sp3
Ancestrologie V1228 B5122
Portable Intel Core 2 17P
OS Vista Home SP2
 

Hors ligne DDdeBerdeux

Problème export GEDCOM
« Réponse #11 le: 09 Avril 2006 à 13:52:45 »
Je pense que vous avez ce problème parce que vous n'enregistrez pas (bouton "Enregistrer" en bas de la fenêtre) le conjoint, après l'avoir saisi, et avant de saisir un enfant.

J'ai fait l'essai suivant:

Nouvelle fiche: création de X,X un homme,

+ conjoint Y,Y

+ enfant X,A (dans la fenêtre de choix de la mère, aucun nom ne paraît, mais je valide quand même)

Enregistrer.

Je retrouve bien X,X NIP 3922

Y,Y NIP 3923

X,A NIP 3924, mais seul le père est enregistré.

Dans la table INDIVIDU, X,A a effectivement pour père 3922, mais pour mère -1.

Dans la table T_UNION, il y a 2 unions:

3922 avec 3923 (normal)

3922 avec -1 (anormal mais cohérent avec la fiche de X,A).

J'ai ensuite supprimé l'individu X,A.

Mais dans la table des unions, les 2 subsistent :!: , 3922/-1 n'a pas été supprimé.

Si par contre, lors de l'enregistrement, j'enregistre l'union du couple avant d'y rattacher un enfant, il n'y a pas de problème.

Il y a donc bien plusieurs problèmes qui subsistent:

-le couple devrait être enregistré avant qu'on puisse y rattacher un enfant,

-on ne devrait pouvoir créer une union, avec un individu qui n'existe pas (-1)

-ce même individu ne devrait pas pouvoir être enregistré comme père ou mère (il ne devrait figurer nulle part, tant qu'il n'a pas été enregistré dans la table INDIVIDU)

-la suppression de l'enfant devrait supprimer l'union uni-latérale qu'il a générée (si cette union n'a pas d'autre enfant).

-la suppression d'un individu devrait entraîner la suppression de l'union.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne b.callens

  • Expert
  • ****
  • Messages: 100
    • Blog personnel
  • Programme: v1040
  • Base: v5.122
Anomalie GEDCOM ?
« Réponse #12 le: 10 Avril 2006 à 16:36:17 »
Bonjour,



Je vous explique comment je procède généralement  pour saisir une famille.



1) Je clique sur "nouvelle fiche"

2) Je saisis le premier enfant du couple (je remplis la fiche totalement)

3) Je clique sur "père" (création, saisie rapide, enregistrement)

4) Le nom du père apparaît (il y a parfois des erreurs à ce stade, l'individu qui s'affiche n'est pas forcément celui qui est saisi : autre bogue ?);

5) Je clique sur "mère", même procédure

6) je clique soit sur "père" ou "mère" puis sur l'onglet "union" où je choisis l'option "mariés"



A la suite d'un tel enregistrement, si je fais une exportation gedcom, apparition d'un mariage fantôme.



Bruno callens     8)
 

Hors ligne DDdeBerdeux

Problème export GEDCOM
« Réponse #13 le: 10 Avril 2006 à 17:38:25 »
J'ai refait la même expérience que vous, et je retrouve effectivement l'union fantôme.

La seule différence avec l'expérience précédente, est que la femme n'est pas -1 mais NULL, et que lorsqu'on supprime les 3 individus, tous les enregistrements sont supprimés (il ne reste pas d'union orpheline).

Mais si après avoir saisi votre premier individu, vous cliquez sur le bouton "Enregistrer" situé dans le bas de la fiche, tout se passe ensuite normalement.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne b.callens

  • Expert
  • ****
  • Messages: 100
    • Blog personnel
  • Programme: v1040
  • Base: v5.122
Anomalie export gedcom
« Réponse #14 le: 10 Avril 2006 à 23:09:00 »
Bonjour,



Cette anomalie pourra-t-elle être corrigée par une mise à jour ?



Merci



Bruno Callens                :?:
 

Hors ligne Horemans

  • AncestroSenior
  • *****
  • Messages: 1 775
    • http://perso.wanadoo.fr/philippe.horemans
Problème export GEDCOM
« Réponse #15 le: 13 Avril 2006 à 18:16:43 »
Je retrouve cette anomalie de mariage excédentaire sur des fiches que je n'ai pas touchées depuis longtemps. Il me semblait qu'une requête permettait de corriger, je n'ai pas retrouvé... mais ai-je bien cherché ?
Plus çà va, plus je me régale...  Et avec  Quisontils, la gestion des actes, c'est facile !   Philippe
 

Hors ligne GERONIMO24

  • AncestroTest
  • Expert
  • ****
  • Messages: 153
  • Remercié: 1 fois
    • Arbre sur Geneanet
  • Programme: 2015-1996-3-2
  • Base: 5.131
  • Système: Windows 10
lecture avec ERREUR des GEDCOM exportés par ANCSTRO
« Réponse #16 le: 26 Avril 2006 à 17:54:39 »
Bonjour à tous les pro.



Je suis toujours cette question car je n'ai pas trouvé de réponse claire.  J'ai rencontré un autre problème car pour éditer mes listes de descendances je passe par VisuGed  pour avoir les mariages et conjoints ce que ne donne pas la  BAO.



Pour certains mariages, en lecture VisuGed,  j'ai un message d'erreur  "enfant N° 1943  mariage  N°754 n'existe pas" et je ne peux éditer l'enfant et sa descendance à partir du couple.

Pourtant cet enfant existe et je peux lire sa fiche avec VisuGed et les parents sont bien cités.  Est-ce qu'une information ne serait pas exportée pour faire la liaison?



PS:  si la BOA permettait d'éditer un arbre avec les mariages et les conjoints  je n'aurais pas besoin de faire ces manipulations et il y aurait moins de BUGS.



Cordialement
Matériel: PC ASUS 16 Go / 1 To  sous Win10
 

Hors ligne GERONIMO24

  • AncestroTest
  • Expert
  • ****
  • Messages: 153
  • Remercié: 1 fois
    • Arbre sur Geneanet
  • Programme: 2015-1996-3-2
  • Base: 5.131
  • Système: Windows 10
lecture avec ERREUR des GEDCOM exportés par ANCSTRO
« Réponse #17 le: 28 Avril 2006 à 17:51:41 »
Bonjour



Complément d'info pour essayer d'avoir une piste de correction.



D'abord, je suis en V504 B4.028



Je n'ai pas vérifié si c'était une erreur à 100% mais pour les couples pour lesquels j'ai des problèmes de lecture des fichiers .GED,  je me suis apperçu que j'avais aussi un problème dans ANCESTRO.



Quand je clique dans le format "Répertoire"  sur un individu d'un couple présentant un problème,  dans la fenêtre inférieur,  je n'ai pas la ligne "son dernier conjoint :  XXXXX".

Le conjoint est pourtant déclaré,  les époux sont dits "Mariés"  et l'évenement "union" est crée.



Peut on avoir une réponse pour un problème qui dure depuis un bon moment?



Papy François
Matériel: PC ASUS 16 Go / 1 To  sous Win10
 

Hors ligne DDdeBerdeux

lecture avec ERREUR des GEDCOM exportés par ANCSTRO
« Réponse #18 le: 07 Mai 2006 à 19:24:03 »
Citation de: "GERONIMO93"
Quand je clique dans le format "Répertoire"  sur un individu d'un couple présentant un problème,  dans la fenêtre inférieur,  je n'ai pas la ligne "son dernier conjoint :  XXXXX".

Le conjoint est pourtant déclaré,  les époux sont dits "Mariés"  et l'évenement "union" est crée.
Le conjoint ne paraissait effectivement que s'il y avait un évènement MARR concernant l'union. Je crois que c'est rectifié dans la dernière version.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne GERONIMO24

  • AncestroTest
  • Expert
  • ****
  • Messages: 153
  • Remercié: 1 fois
    • Arbre sur Geneanet
  • Programme: 2015-1996-3-2
  • Base: 5.131
  • Système: Windows 10
Problème export GEDCOM
« Réponse #19 le: 08 Mai 2006 à 08:30:18 »
BONJOUR DDdeberdeux

Merci d'avoir pris le temps de répondre.



Je suis très étonné,  cela fait un moment qu'il parait avoir un probleme sur la procedure d'export d'un fichier GED et il n'y a aucune réponse.



Est-ce que personne ne ce sert de cette fonction,  cela n'interesse personne  ou  personne n'a trouvé ce qui se passe ?



Cordialement
Matériel: PC ASUS 16 Go / 1 To  sous Win10
 

Hors ligne DDdeBerdeux

Problème export GEDCOM
« Réponse #20 le: 08 Mai 2006 à 11:51:43 »
Bonjour,

Je confirme que dans la V515, le dernier conjoint apparaît bien dans le répertoire, même s'il n'y a pas eu d'évènement mariage enregistré.

Le problème des unions "fantômes" n'est pas un problème gedcom. Si c'est unions sont exportées, c'est qu'elles existent bien dans les tables de la base. Les raisons de leur existence sont dans l'exécutable ancestrologie.exe lui-même.

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)