Auteur Sujet: Violation d'accès avec la V530  (Lu 2547 fois)

plus minus reset

0 Membres et 1 Invité sur ce sujet

Hors ligne DDdeBerdeux

Violation d'accès avec la V530
« le: 19 Juillet 2006 à 01:05:50 »
Bonsoir,

Utilisant Firebird serveur, je peux lancer 2 sessions d'ancestrologie, l'une par ancestrologie.exe, l'autre par ancestrologie2.exe, la base pouvant être locale ou distante (poste linux avec FB2.0 en réseau).

Avec la V527 pas de problème. Mais avec la V530, l'accès par ancestrologie2.exe (lancé seul) à la base distante, provoque des violations d'accès mémoire quand on accède au menu, dont on ne sort que par le gestionnaire de tâches, puisqu'il est alors impossible de quitter normalement le logiciel. Il semble que ces violations n'apparaissent qu'après visualisation d'un individu avec photo d'identité?

Le retour à ancestrologie2.exe V527 fait disparaître le problème.

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne DDdeBerdeux

Violation d'accès avec la V530
« Réponse #1 le: 03 Août 2006 à 09:46:49 »
"Va comprendre Charles" aujourd'hui çà marche avec la V530 dans les mêmes conditions... Faut-il vraiment mettre [Résolu] quand l'anomalie reste un mystère?

A+

André
Une application pleinement satisfaisante est toujours complétée par une mise à jour buggée. (Loi des Mises à Jour)
 

Hors ligne BLefebvre

  • AncestroExpert
  • *****
  • Messages: 885
Violation d'accès avec la V530
« Réponse #2 le: 03 Août 2006 à 13:18:45 »
Des violations d'accès, j'en ai malheureusement eu avec TOUTES les versions d'ancestrologie que j'ai utilisées, dont la 530, et encore hier soir.

Je m'en suis fait une raison, et je prends maintenant ça comme un défaut du produit dont il faut faire avec.

Dans mon cas, c'est quand j'accède au répertoire. Tout va bien, et puis brutalement, sans crier gare, violation d'accès. Je sors, je relance, et ça repart.

J'avais trouvé le cas où je cliquai sur répertoire alors que l'enregistrement précédent ne semblait pas complètement achevé, mais maintenant je prend mon temps, mais celà arrive encore.
XP SP3 V1360 B5.130
 

Hors ligne Gerdes

  • AncestroJunior
  • ****
  • Messages: 308
  • Remercié: 2 fois
  • Programme: v2015-1995.11
  • Base: v5.131
  • Système: W10
Violation d'accès avec la V530
« Réponse #3 le: 03 Août 2006 à 16:00:19 »
Bonjour,

Des violations d'accès j'en ai aussi avec, presque, toutes les versions, aujourd'hui la 530 sous XP.

J'ai remarqué que ces violations arrivent brutalement après au moins 2 h d'utilisation, je sors avec le gestionnaire de taches, je relance et ça repart pour 2 à 3 h.

Je précise que je n'ai jamais eu de perte de données.

Je ne sais pas ce qui est en cause, Ancestrologie, l'ordi, les données, la vitesse du vent ?  :D  mystère

A part ça Ancestro est quand même génial  :!:

Gerdes
Ancestro v2015-1996.3 Base 5.131 
Arbres 2009-1.9.18
Windows 10 - 64 bits
i Core 7
Ram 8 Go
DD 1 To + 500 Go
 

Hors ligne BLefebvre

  • AncestroExpert
  • *****
  • Messages: 885
Violation d'accès avec la V530
« Réponse #4 le: 03 Août 2006 à 18:31:38 »
Et les temps de réponse sont aussi de plus en plus longs avec le temps. Dès qu'on sort d'ancestrologie et qu'on le relance, le temps redevient normal.

Y a-t'il une durée d'utilisation limite avant dégradation?

Sinon, pas de perte de données, ni de dégradation de la base non plus quand il faut sortir par le gestionnaire de tâches.
XP SP3 V1360 B5.130
 

Hors ligne Pierrot

  • AncestrArbres -Test
  • AncestroSenior
  • *****
  • Messages: 1 044
  • Remercié: 1 fois
  • Programme: V.1360
  • Base: 5.130
Violation d'accès avec la V530
« Réponse #5 le: 03 Août 2006 à 19:20:15 »
Citation de: "blefebvre"
Des violations d'accès, j'en ai malheureusement eu avec TOUTES les versions d'ancestrologie que j'ai utilisées, dont la 530, et encore hier soir.

Je m'en suis fait une raison, et je prends maintenant ça comme un défaut du produit dont il faut faire avec.

Dans mon cas, c'est quand j'accède au répertoire. Tout va bien, et puis brutalement, sans crier gare, violation d'accès. Je sors, je relance, et ça repart.

J'avais trouvé le cas où je cliquai sur répertoire alors que l'enregistrement précédent ne semblait pas complètement achevé, mais maintenant je prend mon temps, mais celà arrive encore.




J'ai le même problème, mais contrairement à blefebvre, je trouve que cela devient génant, car après chaque violation il faut relancer le programme, et contrôler que les données soit bien enregistrées, et j'ai de plus en plus de vioalation avec la version 530

Pierrot


Windows XP Pro SP 3 - 2048 Mo - Affichage 1024x768
 

Hors ligne BLefebvre

  • AncestroExpert
  • *****
  • Messages: 885
Violation d'accès avec la V530
« Réponse #6 le: 04 Août 2006 à 19:01:07 »
Aucune violation d'accès cet après-midi alors que j'ai travaillé pendant plusieurs heures. Mais je parie que sitôt ce message envoyé, ça va se planter.

Mais c'est vrai que c'est génant,
XP SP3 V1360 B5.130
 

Hors ligne BLefebvre

  • AncestroExpert
  • *****
  • Messages: 885
Violation d'accès avec la V530
« Réponse #7 le: 04 Août 2006 à 19:08:36 »
Gagné! Violation en voulant quitter ancestrologie.
XP SP3 V1360 B5.130
 

Hors ligne Pierrot

  • AncestrArbres -Test
  • AncestroSenior
  • *****
  • Messages: 1 044
  • Remercié: 1 fois
  • Programme: V.1360
  • Base: 5.130
Violation d'accès avec la V530
« Réponse #8 le: 07 Août 2006 à 19:04:26 »
Citation de: "blefebvre"
Gagné! Violation en voulant quitter ancestrologie.




Samedi, j'ai remis l'exe de la version 527, puis j'ai refait une mise à jour via "Verifier les mise à jour sur internet" et après pas mal d'heures d'encodage, plus de violation  :P



Pourvu que ça dure  :lol:

Pierrot


Windows XP Pro SP 3 - 2048 Mo - Affichage 1024x768