Auteur Sujet: Bug de lancement "arbres"  (Lu 3948 fois)

plus minus reset

0 Membres et 1 Invité sur ce sujet

Hors ligne bubmate

  • Débutant
  • *
  • Messages: 6
Bug de lancement "arbres"
« le: 27 Octobre 2008 à 09:38:32 »
J'ai installé et validé ancestrologie et Arbres achetés ces 2 derniers jours.
Quand je veux lancer les arbres j'ai le message; erreur d'execution de la DLL.
J'ai reinstallé le fichier téléchargé et même après effacement du plugin arbres, mais en suis resté avec le meme bug.
Que faire?
 

Hors ligne Facon

Bug de lancement "arbres"
« Réponse #1 le: 27 Octobre 2008 à 09:57:07 »
Bonjour,
Bienvenue sur le forum,
Afin de pouvoir t'aider, peux-tu nous indiquer les versions Ancestrologie (application et base) ainsi que la version des Arbres. Pour les Arbres, tu trouves la version dans le menu Plugins > Arbres pour....
Christian
 

Hors ligne bubmate

  • Débutant
  • *
  • Messages: 6
Bug de lancement "arbres"
« Réponse #2 le: 27 Octobre 2008 à 10:18:58 »
Voici les réponses:

Machine et Système: HP pavilion 061  Windows XP ed familiale

Ancestrologie: v820 box v5.504   ou 2008.990.5.105 ( informations trouvées en des emplacements différents.....)

Arbres: 2008.1.7.6

a suivre.... L.B.
 

Hors ligne Facon

Bug de lancement "arbres"
« Réponse #3 le: 27 Octobre 2008 à 10:42:33 »
Bonjour,
Pour ce qui concerne les versions:
 - Les versions Ancestrologie et base se lisent dans la barre de titre d'Ancestrologie si tu disposes de la clé d'activation, ce qui semble être le cas. Le dernier module d'installation complète disponible est v820 b5.104 et il met en place le plugin Les Arbres.... à la version 1.6.51.
Il est connu que cette version pouvait être lancée une fois mais au lancement suivant il y a un message d'erreur tel que celui que tu indiques.
Ce plugin a été corrigé pour éviter cette anomalie, il faut pour cela charger depuis le site Les Arbres v1.7.6 et de mettre en place ce plugin en lançant l'exécutable MAJArbredll.exe. Au prochain lancement d'Ancestrologie ce plugin sera chargé.
Compte tenu de tes indications je pense que tu as déjà effectué cette opération. Si oui, est-ce que le souci persiste?

Pour ta gouverne, l'outil de migration ne met pas à jour les plugins, personnellement je n'ai pas adopté la version v990.
Christian
 

Hors ligne bubmate

  • Débutant
  • *
  • Messages: 6
Bug de lancement "arbres"
« Réponse #4 le: 27 Octobre 2008 à 11:08:31 »
Bonjour,

Un grand merci pour ta réponse.
J'ai vérifié pas à pas ta proposition, mais, hélas, le bug n'est pas corrigé§
Est-ce que je pourrais tout désinstaller et repartir à zéro ? j'ai toujours peur de perdre des codes ou autres autorisations
à suivre vers la solution ....
 

Hors ligne Facon

Bug de lancement "arbres"
« Réponse #5 le: 27 Octobre 2008 à 11:21:24 »
Bonjour,
Il n'y a pas d'obstacle à repartir de zéro. La seule précaution à prendre est la sauvegarde des données mais je pense que tu viens juste de commencer donc cela ne devrait pas occasionner trop de soucis.
Tu mets à l'abri tes clefs d'activation AncestroKey.lic et AncestrArbresKey.lic

Pour effectuer cette opération:
 - A l'aide du module Ajout/Suppression de programmes de Windows tu désinstalles Ancestrologie,
 - Dans C:\Program Files\Ancestrologie tu peaufines le nettoyage et même chose dans Mes Documents\Ancestrologie (tu peux supprimer les deux répertoires \Ancestrologie).
 - Tu réinstalles Ancestrologie et tu positionnes tes clés d'activation,
 - Tu lances Ancestrologie pour vérifier qu'il fonctionne correctement.
 - Tu charges depuis le site l'exécutable de màj des Arbres v1.7.6 et tu le positionnes comme tu veux.
 - Tu stoppes Ancestrologie et tu lances l'exécutable de màj des Arbres.
Au prochain lancement d'Ancestrologie, le nouveau plugin sera chargé et à priori les Arbres devraient fonctionner sans l'inconvénient rencontré.
Il existe une autre version des Arbres au stade béta (v1.7.16 RC) mais le développement n'est pas terminé, je pense que Bruno devrait prochainement la mettre en service.
Christian
 

Hors ligne bubmate

  • Débutant
  • *
  • Messages: 6
Bug de lancement "arbres"
« Réponse #6 le: 27 Octobre 2008 à 14:21:51 »
Re-bonjour et d'abord merci pour m'aider a trouver es solutions.

J'ai donc applique a la lettre tes recommandations. J'ai même pousse le luxe de nettoyer le registre de toutes les refs a ancestrologie et annexes.
Le rechargement s'est opéré sans problème.
Le lancement a choppé sur message: violation de l'adresse 0049666B.....
Le programme a cependant redémarré sans bug apparent.
Par contre la situation des arbres reste la même: blocage de solutions....
Cela devient quelque peu désespérant: et comme toujours on finit par culpabiliser.... et pourtant

à suivre      Louis
 

Hors ligne Facon

Bug de lancement "arbres"
« Réponse #7 le: 27 Octobre 2008 à 14:37:27 »
Bonjour,
Peux-tu indiquer l'emplacement à partir duquel tu charges la mise à jour des Arbres et dans la foulée tu fais un clic droit sur le fichier puis Propriétés. Tu liras la version ainsi que la taille du fichier.
Christian
 

Hors ligne bubmate

  • Débutant
  • *
  • Messages: 6
Bug de lancement "arbres"
« Réponse #8 le: 27 Octobre 2008 à 14:58:25 »
Suite.....

Je place tous mes téléchargements dans le dossier c:\download
Le fichier de lancement est:
MAJarbredll                   2,96Mo            ver 2008 1.7.6.

Est-ce incorret ?

Louis
 

Hors ligne Facon

Bug de lancement "arbres"
« Réponse #9 le: 27 Octobre 2008 à 15:46:53 »
Bonjour Louis,
Oui, c'est correct.
J'ai moi même refait sur une machine d'essai la même installation, la mise à jour des Arbres avec le fichier que tu as indiqué et je ne rencontre pas ce type d'anomalie. A l'inverse sur l'installation de la v820, le premier lancement des Arbres v1.6.51 était correct mais plus possible pour le suivant. Le passage en v1.7.6 a réglé cette affaire.
Je suppose que tu vois bien la version 2008.1.7.6 dans le menu Plugins > Arbres pour Ancestrologie version...

Au cours de la màj du plugin, une fenêttre indique le Dossier de destination. Par défaut ce chemin est: C:\Program Files\Ancestrologie\PlugIns. J'imagine que tu as fait l'installation d'Ancestrologie selon les paramètres par défaut, sinon il faut faire l'adaptation dans cette fenêtre.
En définitive, ces difficultés sont rencontrées sur quelle version Ancestrologie: v820 ou v990?

Tu confirmeras tu fais bien cette mise à jour des Arbres avec Ancestrologie stoppé.
« Modifié: 27 Octobre 2008 à 15:50:51 par Facon »
Christian
 

Hors ligne Bruno T.

  • Administrateur
  • AncestroGrandMaitre
  • *****
  • Messages: 4 600
  • Remercié: 67 fois
    • Notre Généalogie
  • Programme: 1998.1.6 - dev: 2001.3.16
  • Base: 5.131 emb/serv
  • Système: w10x64
Bug de lancement "arbres"
« Réponse #10 le: 27 Octobre 2008 à 22:43:59 »
....Je suppose que tu vois bien la version 2008.1.7.6 dans le menu Plugins > Arbres pour Ancestrologie version...
Tout ça m'amène à cette question complémentaire: peux-tu regarder la version du fichier DllArbres.dll dans le dossier .....\Ancestrologie\plugins\ ainsi que celle du programme Ancestrologie.exe dans .....\Ancestrologie\ (les .... représentent le chemin où est installé ancestrologie - par défaut ce devrait-être c:\Program Files) , ce doute car tu dis avoir installé 2 versions, ont-elles été installées au même endroit...
Téléchargez des images supplémentaires pour Ancestr'Arbres Images au choix enrichissez en ajoutant les votres
A+    Bruno
                                                                                               
 

Hors ligne bubmate

  • Débutant
  • *
  • Messages: 6
Bug de lancement "arbres"
« Réponse #11 le: 28 Octobre 2008 à 09:00:19 »
Bonjour (ce matin pluvieux ici...)

La version de DLLarbre est 2008.1.6.5.1
Quelque peu frustré, j'ai tout effacé et tout réinstallé dans un même répertoire en prenant soin de n'intervenir que lorsque tous les fichiers étaient en place.
Apparemment cela marche ! et je n'ose plus y toucher...

Merci pour ton aide et tes conseils précieux.
Je me permettrai certainement de refaire appel ultérieurement à tes compétences.
Cordialement                    Louis Bubenicek